Login  
Search All Forums
Dart Home | PowerTCP Sockets for .NET | Custom Development Reply | PowerTCP Sockets for .NET (Secure and Standard) Topics | Forums   
AuthorForum: PowerTCP Sockets for .NET (Secure and Standard)
Topic: Using Dart with new Net 5
delpiero

From: USA
Posts: 5
Member Since: 03/01/17
posted November 12, 2020 9:31 PM

Hi,
I have "Dart.Sockets.45.dll" v4.5.6 working perfectly fine with Net Framework v4.8
When I upgraded to Net 5 there is an issue with license not being installed.
Can you please help me?
delpiero

From: USA
Posts: 5
Member Since: 03/01/17
posted November 13, 2020 1:51 PM

I was able to embed the license but this is what I get now..

PlatformNotSupportedException: PowerTCP Sockets for .NET not compatible with CLR version 5.0.0.
Jamie Powell (Admin)

From: Rome, NY USA
Posts: 436
Member Since: 03/13/07

Extra Support Options
Custom Application Development

posted November 13, 2020 1:51 PM

Thank you for your post.

.NET 5.0 is based off of .NET Core so you will want to use the Dart.Sockets.Standard dll. No code changes should be required. We are currently in the QA process to update our MSI installers, but the dlls are available from Nuget within visual studio. You can view the website here: https://www.nuget.org/packages/PowerTCPSockets.Standard/

Please make sure you are using version 4.5.7+ for .NET 5.0 compatibility.

Please email sales@dart.com if you have any questions or are unable to use Nuget.

All the best,
Jamie
Reply | PowerTCP Sockets for .NET (Secure and Standard) Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX