Login  
Search All Forums
Dart Home | PowerTCP Web for ActiveX | Custom Development Reply | PowerTCP Web for ActiveX Topics | Forums   
AuthorForum: PowerTCP Web for ActiveX
Topic: Problem with newer certificates
PeterD

From: Australia
Posts: 3
Member Since: 09/03/14
posted May 19, 2015 7:01 PM

We started using PowerTCP Web for ActiveX about six months ago to allow us to download resources from within a VB6 application via HTTPS. The VB6 native controls, of course, do not support HTTPS.

While that worked fine for a while, we recently replaced a older about-to-expire SHA-1 certificate with a new SHA-2 certificate.  And the download ceased to work. There was no error - no "Error" event - no State change.  It just didn't work.

Is this is a known issue?
Jason Farrar (Admin)

From: USA
Posts: 223
Member Since: 07/24/07

Extra Support Options
Custom Application Development

posted May 26, 2015 4:22 PM

It isn't a known issue. I tried hitting a couple of sites using SHA2 certificates (thawte.com and symantec.com both have SHA2 certificates) and those worked correctly. Web for ActiveX does use wininet so it could potentially be a setting in IE that is causing the problem but was unable to reproduce the issue as described by changing settings. Do you have a server we can try to reproduce against?
Reply | PowerTCP Web for ActiveX Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX