Login  
Search All Forums
Dart Home | Custom Development Reply | Licensing Issues Topics | Forums   
AuthorForum: Licensing Issues
Topic: Dart.SNMP.Manager does start on Win7 system with language set to "azeri"
oa7018

From: Nuernberg, Germany
Posts: 13
Member Since: 10/18/04
posted July 24, 2014 9:20 AM

While constructing an instance of Dart.Snmp.Manager from SNMP for .NET (Dart.SNMP.dll version 4.4.0.1), one of my users gets the exception "Dart.Snmp.Manager, Dart.Snmp'
is missing from your project's 'licenses.licx' file. If your project does not already include this file, add a new text file named 'licenses.licx' to your PROJECT (not the Solution) and ensure the 'Build Action' is set to 'Embedded Resource'. Then add the line shown at top (without the quotes) and rebuild all. Refer to the "Licensing and Trial Operation" section of the documentation for further assistance."

It's running on Win7 64Bit embedded system with system language setting "azeri". I have seen in the change history that there is a know issue with azeri in this version, but even after changing system language settings back to english, application is still throwing the exception. I am sure the DLL is not renamed after the build and the license is valid. The upgrade to the latest stack version is currently in progress, but we need a quick solution for the customer.

Could you please give me an advise which windows settings have to be changed to successfully start the Dart.Snmp.Manager.



Stack:
Paramter: CrashReason - 'Dart.Snmp.Manager, Dart.Snmp'
is missing from your project's 'licenses.licx' file. If your project does not already include this file, add a new text file named 'licenses.licx' to your PROJECT (not the Solution) and ensure the 'Build Action' is set to 'Embedded Resource'. Then add the line shown at top (without the quotes) and rebuild all. Refer to the "Licensing and Trial Operation" section of the documentation for further assistance.
Paramter: StackTrace
  at 1.0.0(String , Type , Environment , Boolean , String )
  at 1.0.1(Type )
  at 1.0.0(Type )
  at Dart.Snmp.Manager..ctor(IContainer container)
  at Dart.Snmp.Manager..ctor()

Jamie Powell (Admin)

From: Rome, NY USA
Posts: 377
Member Since: 03/13/07

Extra Support Options
Custom Application Development

posted July 30, 2014 1:48 PM

Thank you for your post. This issue has been resolved with the release of PowerSNMP for .NET version 4.5.

If you have an active Subscription, please log into your Customer Center account to gain access to this update. www.dart.com/customercenter

If your Subscription has expired, please contact sales@dart.com for upgrade information.

Best regards,
Jamie
Reply | Licensing Issues Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX