Login  
Search All Forums
Dart Home | Custom Development Reply | Licensing Issues Topics | Forums   
AuthorForum: Licensing Issues
Topic: Application named in license does not match...
MattZUSmith

From: Mount Arlington, NJ USA
Posts: 5
Member Since: 08/22/13
posted August 22, 2013 11:11 AM

While constructing an instance of Dart.Sockets.Tcp from Sockets for .NET (Dart.Sockets.dll version 4.4.0.3), one of my users gets the error "Application named in license does not match using application."

Stack:
  at 1.0.0(Object , String , Stream )
  at 1.0.0(Object , Assembly , String& )
  at 1.0.0(Object , Environment , Boolean&, String& )
  at 1.0.1(Object )
  at 1.0.0(Object )
  at Dart.Sockets.PtyBase..ctor()
  at Dart.Sockets.Tcp..ctor()

Our license is valid, and this is only happening to this particular user. What could be going on?
Nick B (Admin)

From: Utica, NY USA
Posts: 567
Member Since: 05/25/10

Extra Support Options
Custom Application Development

posted August 22, 2013 11:18 AM

Hello,

This indicates that the user has renamed the executable. The executable cannot be renamed after compiling.
MattZUSmith

From: Mount Arlington, NJ USA
Posts: 5
Member Since: 08/22/13
posted August 22, 2013 1:43 PM

Okay, except the executable has not be renamed. I've had the user re-install from a known good installation, and the problem recurs. What else could be happening?
Nick B (Admin)

From: Utica, NY USA
Posts: 567
Member Since: 05/25/10

Extra Support Options
Custom Application Development

posted August 22, 2013 1:53 PM

Hello,

Is their system configured for Azeri (az), Azeri-Latin (az-Latn), Azeri-Latin-Azerbaijan (az-Latn-AZ), Turkish (tr), or Turkish-Turkey (tr-TR)? This may be resolved in the latest release, see the release history here: http://www.dart.com/ptsknet_relhist.aspx

You may download the latest version here (trial is licensable, and your 4.4 license is valid for this version):
http://www.dart.com/sockets-net-trial.aspx
MattZUSmith

From: Mount Arlington, NJ USA
Posts: 5
Member Since: 08/22/13
posted August 30, 2013 5:18 PM

Although the user's system was not configured for any language/culture other than en-US, upgrading to version 4.4.4.8 of the sockets component solved the issue. Thank you.
Reply | Licensing Issues Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX