Login |  Register  
Search All Forums
AuthorForum: PowerTCP FTP for .NET
Topic: Is the old secureftp.dll supposed to work with TLS?

From: Göteborg, Sweden
Posts: 9
Member Since: 03/16/04
posted May 22, 2012 7:48 AM


We still use the old Dart.PowerTCP.SecureFtp.dll (version Now we test it against a ftp server with the sample application (MGet.exe) and the test certificate that followed the product (PowerTCPTest.pfx). The result of this test is an error "The handle specified is invalid" and the tracelog from the sample app shows:
"<--- 220 Microsoft FTP Service
<--- 234 AUTH command ok. Expecting TLS Negotiation."

When testing with another ftp client (for example FileZilla) everything works.

This makes us wonder if it is possible at all to use secureftp.dll (ver with TLS?

Tony Priest

From: Utica, NY USA
Posts: 8466
Member Since: 04/11/00
posted May 22, 2012 9:15 AM

While that is a rather old version that is no longer supported, I do not recall any issues with TLS-P that might be causing this. My best suggestion would be for you to download the latest version and use the sample app to see if you can login.

-Non-current subscribers must contact sales@dart.com to update subscription and receive continued support as needed.

Reply | PowerTCP FTP for .NET Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX