Login  
Search All Forums
Dart Home | PowerTCP SSL for ActiveX | Custom Development Reply | PowerTCP SSL for ActiveX Topics | Forums   
AuthorForum: PowerTCP SSL for ActiveX
Topic: Problems with Dart and Momentum FTPS server
Paul Smith

From: Burnsville, MN USA
Posts: 2
Member Since: 03/13/09
posted April 3, 2009 6:08 PM

I'm having problems using the DART SSL for ActiveX tool to transfer files to the Momentum FTPS server Ė I canít transfer files of around 200K. The problem does not happen with smaller (100 byte) files. The Filezilla client does not have this problem.


To reproduce the error in a controlled environment I set up a Momentum FTPS server at our site. I downloaded and installed the latest trial version, PowerTCP_SSL_ActiveX_Trial.exe on a test machine. 

I then ran the sample program at C:\Program Files\PowerTCP\SSL for ActiveX\Samples\VB6\SecureFtp\Client and tried to transfer a file.

The login details for this server are:

Host: www.mhcdocumentexpress.com
Port: 990
Username: testuser0135
Password: iwtdwstp0135
Path: /
Timeout: 60
PASV Mode: Checked
Authentication: Implicit Normal
Ignore Invalid Date, Ignore Invalid Hostname, Ignore Untrusted Root, and Manual Port Selection can be either checked or unchecked.

The progress bar advances to indicate the file is being transferred, and then there is an error and the connection drops, resulting in a zero length file on the FTPS server.

Is there anything else you need me to provide for you to be able to look at this?

Paul Smith
MHC Software
Jason Farrar (Admin)

From: USA
Posts: 223
Member Since: 07/24/07

Extra Support Options
Custom Application Development

posted April 6, 2009 9:21 PM

I've reproduced the issue that you are seeing with the credentials that you've posted. I've tried modifying any parameters that I thought may be applicable but no luck. Does the server have any logging on it's end?

As a quick test I've connected to a few other servers (test servers locally and a few private ones) that use implicit security and this particular server is the only one that displays this issue with our ActiveX control. So I'd like to see any server side logs or entries in the event log if it creates any when these errors occur.

For me the transfers always stop at either 65416 bytes or 49062 bytes, I can't even get 100k across the wire. I looked at the transmission in Wireshark and everything looks OK, until the server sends a close command for the data channel. Then the server just reports that error and then drops the connection. It is strange that the server isn't saving any of the data that is supposedly being sent, normally you expect the ~40-60k to be there partially uploaded.
Paul Smith

From: Burnsville, MN USA
Posts: 2
Member Since: 03/13/09
posted April 7, 2009 11:28 AM

We created a sub-folder on your FTP root called "logs" that now contains the logs from the server. All future logs will also be created in that folder. Thank you for looking at this.

Paul Smith
MHC Software
Reply | PowerTCP SSL for ActiveX Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX