Login  
Search All Forums
Dart Home | PowerTCP Server for ActiveX | Custom Development Reply | PowerTCP Server for ActiveX Topics | Forums   
AuthorForum: PowerTCP Server for ActiveX
Topic: URL Monitor with Server Activex
fad

From: Pedro Leopoldo, Brazil
Posts: 3
Member Since: 07/17/06
posted May 9, 2008 2:23 PM

Hi!

I'm sorry my english, i'm brazilian.

I need a url monitor, to block or to alow a website list, with Visual Basic 6.0. So i want use the Server Activex. Only get the URL that the clients browsers are asking for and compare with my list to block or to alow.

In the server proxy sample, i marked the CERN Proxy Type option and put port 8080. In the client browser i set the proxy to server ip and put the port 8080, only in HTTP proxy and marked to Donīt use Proxy in local address.

It works well in some cases. But it fails when I try to search images in google for example or when i search in google and clik in link with a kind of script. Like this: http://www.google.com.br/url?q=http://www.test.com/

Fails link:
http://www.google.com.br/url?q=http://www.test.com/organizations.htm&sa=X&oi=smap&resnum=1&ct=result&cd=1&usg=AFQjCNHuvIZt5SPnyk_hUyow0sFzSJ4XZQ

or

http://images.google.com.br/imgres?imgurl=http://static.howstuffworks.com/gif/nuclear-test-1.jpg&imgrefurl=http://science.howstuffworks.com/nuclear-test.htm&h=434&w=400&sz=27&hl=pt-BR&start=1&um=1&tbnid=ikGI0NaN_FcpSM:&tbnh=126&tbnw=116&prev=/images%3Fq%3Dtest%26gbv%3D2%26um%3D1%26hl%3Dpt-BR%26sa%3DN

What Can I do to solve this problem?

Are there any others situations that kind of problem ocorrs?

Any suggest to do better this things?
fad

From: Pedro Leopoldo, Brazil
Posts: 3
Member Since: 07/17/06
posted May 10, 2008 8:33 AM

Maybe this is a bug...
 
The Proxy Server Sample fails when I use google, whith CERN proxy type, it does not access when has http://www.google.com.br/url?q= or some script in the URL.
 
It fails trying to connect:
 
Relayer.Connect "http://www.google.com.br/url?q=http://www.test.com/organizations.htm&sa=X&oi=smap&resnum=1&ct=result&cd=1&usg=AFQjCNHuvIZt5SPnyk_hUyow0sFzSJ4XZQ", 80, LocAddr
 
 
What can I do?
fad

From: Pedro Leopoldo, Brazil
Posts: 3
Member Since: 07/17/06
posted May 10, 2008 8:35 AM

The same occurs when i trying to connect "http://support.dart.com/reply?topicid=7806"... it is a script problem?
Jason Farrar (Admin)

From: USA
Posts: 223
Member Since: 07/24/07

Extra Support Options
Custom Application Development

posted May 13, 2008 3:35 PM

Hello,

I've reviewed the sample and there were some errors in it that were causing this. To be fair, the sample was created to simply demonstrate that this is possible. I'll send you an updated sample with the changes needed for what you are trying to do to work.
Reply | PowerTCP Server for ActiveX Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX