Search All Forums
Dart Home | PowerTCP SSL for ActiveX | Custom Development Reply | PowerTCP SSL for ActiveX Topics | Forums   
AuthorForum: PowerTCP SSL for ActiveX
Topic: Error [10014] Invalid argument accessing \download\008\

From: Greensboro, NC USA
Posts: 7
Member Since: 10/08/01
posted June 7, 2007 2:03 PM

I am trying to get two instances of and application with the SecureFTPServer control to run on the same PC off the same hostipaddress. One using no authentication on port 21, another using atImplicitNormal on port 990. Whichever exe loads first, works. The second allows the login (jumps to the _login event) then gets the error Error [10014] Invalid argument accessing \download\008\ or whatever the User.currentpath is set to. I am using the AxctiveX control with VB6 sp5.

From: Rome, NY USA
Posts: 315
Member Since: 03/15/06
posted June 8, 2007 2:39 PM


Regarding the query, please note that the error 10014 generally means that system detected an invalid pointer address in attempting to use a pointer argument of a call. This error occurs if an application passes an invalid pointer value, or if the length of the buffer is too small.

I tried to replicate this by running two instances of Secure FTP Server. I have used the EXE of default “SecureFTP Server” sample located at the following location:

C:\Program Files\PowerTCP\SSL for ActiveX\Samples\Vb6\SecureFtp\Server

I have been able to connect Secure FTP client applications to both of these instances. Moreover, I have also tried to retrieve and store the files and it worked fine at my end. I have used the latest version of SSL for Active X (2.0.7) and the version of environment is VB 6.0(SP6).

I would request you to please provide us following information so that we can narrow down the issue further:

(1) Trace log of communication between client and server.

(2) A small server application (in zip format) so that we can check this issue at our end. Please send the application to support@dart.com with subject as the topic ID of this forum post.

Any further information to isolate the issue would be highly appreciated.


From: Greensboro, NC USA
Posts: 7
Member Since: 10/08/01
posted June 15, 2007 12:33 PM

I figured out what the problem was. When I passed the ftproot parameter to the .start method, The path "c:\Romsxfer" causes the error "c:\Romsxfer\" does not. The server examples include the last backslash on the root parameter.
Reply | PowerTCP SSL for ActiveX Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX