Login  
Search All Forums
Dart Home | PowerTCP Zip Compression for .NET | Custom Development Reply | PowerTCP Zip Compression for .NET Topics | Forums   
AuthorForum: PowerTCP Zip Compression for .NET
Topic: Using PowerTCP Zip for .Net on Windows Vista (x64)
jwaterman

From: Richmond, BC Canada
Posts: 5
Member Since: 03/06/07
posted March 13, 2007 2:46 PM

We've recently upgraded our development workstations to Windows Vista x64 Edition. We're now getting error messages when compiling projects that have compiled properly in the past:
"Exception occurred creating type 'Dart.PowerTCP.Zip.Archive, Dart.PowerTCP.Zip, Version=1.1.1.0, Culture=neutral, PublicKeyToken=5966291b8955e4bb' System.ComponentModel.LicenseException: This product is not registered and a trial license is not present. You must install this product to enable a 30-day trial development license"

Any ideas on getting this to work under Vista?
Raj

From: Rome, NY, USA
Posts: 389
Member Since: 02/01/06
posted March 13, 2007 5:19 PM

Please try the steps mentioned by Tony, on the following thread:
http://support.dart.com/postings?topicid=7309

Do let me know if you need further assistance.

Regards,
Raj
jwaterman

From: Richmond, BC Canada
Posts: 5
Member Since: 03/06/07
posted March 13, 2007 6:00 PM

I tried something similar earlier, but it didn't work, so I followed the steps exactly as listed in the other post. It did not work, so I tried again after turning off User Account Control first and it still didn't work.

I'm wondering if this may be an x64 issue more than a Vista issue (installs into C:\Program Files(x86)\PowerTCP\ instead of C:\Program Files\PowerTCP\). Does the product run correctly on the x64 version of XP Pro?

Any other ideas would be appreciated...

Thanks,
Jason
jwaterman

From: Richmond, BC Canada
Posts: 5
Member Since: 03/06/07
posted March 13, 2007 8:06 PM

Okay - it looks like I found a workaround - it does appear to be related to the fact I'm running on the x64 version of Vista.

I used the Microsoft SysInternals Process Monitor utility to trace which file system location or registry entry the LC.exe utility was triggering the Dart.PowerTCP.Zip.dll file to look for the license information during the build of the license resource information. It appears that it searches for a REG_SZ entry "Zip Compression for .NET" in the key HKLM\SOFTWARE\Dart\PowerTCP\License\ and doesn't find it there.

Next, I ran the Process Monitor utility to watch where the DartRegister.exe utility was writing the license information on registration. It was putting the license information in the registry key at HKLM\SOFTWARE\Wow6432Node\Dart\PowerTCP\License\. This is probably due to the fact that it's a native 32-bit application running on 64 bit windows and, if I recall correctly, the registry entries are automatically redirected to the Wow6432Node subkey.

Anyway, I just copied the values that it placed into subkey of Wow6432Node and moved it up the the proper key that the Managed component was looking for and this resolved the issue. It all makes sense in hindsight.

Hope this helps somebody from a few days of frustration.

Jason
Dugrhill

From: Granger, IN USA
Posts: 5
Member Since: 11/07/11
posted December 21, 2016 2:19 PM

Jason,

Thanks SO MUCH! I am running Windows 7 and ran into the issue that you described below. I used your work-around and it fixed my issue.

THANKS!

Doug
manala

From: Egypt
Posts: 2
Member Since: 04/26/18
posted April 27, 2018 4:03 PM

I have the same problem
can u help me plz
Reply | PowerTCP Zip Compression for .NET Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX