Search All Forums
Dart Home | PowerTCP Web for ActiveX | Custom Development Reply | PowerTCP Web for ActiveX Topics | Forums   
AuthorForum: PowerTCP Web for ActiveX
Topic: '+' are converted to spaces during post

From: Portland, OR USA
Posts: 21
Member Since: 05/01/00
posted November 25, 2006 12:26 PM

Using Webtool 1.8.1.

I am posting to this page and I get an "..unexpected error...".

So I am troubleshooting the problem with a sniffer. I noticed that when I send a string which contains '+' characters to be posted, the sniffer shows the '+' characters being replaced with blanks.

Why is this happening?

The sniffer I am using is Http Analyzer from http://www.ieinspector.com which can anyalze https packets.


From: Rome, NY USA
Posts: 315
Member Since: 03/15/06
posted November 28, 2006 12:13 PM

Hello Salama,

I tried to replicate the said scenario, however was unable to do so. I tried to send a String which contains ‘+’ characters and I was able to view these characters. I have tried sending Username and Password as String parameters through our sample “MultiPartPost”. This sample is located at the following default location:

C:\Program Files\PowerTCP\Web Tool\Samples\Web\Vb6\MultiPartPost

(1) Ran the sample and then added a Variable with name “MerchantLogin” and Value is “Sample”.

(2) Added another variable with the name “Password” and value is “sample+9876”.

I was able to view the entire password (including + character) in the sniffer. I have used the same sniffer which you have specified in your post. Obviously, I was not able to login because of an incorrect username and password.

I would suggest you to model your application in this way and then let us know whether it fulfills your requirements or not.

I hope this is of help.

Reply | PowerTCP Web for ActiveX Topics | Forums   
This site is powered by PowerTCP WebServer Tool PowerTCP WebServer for ActiveX